Ipv6NdPrefixInformation¶
Namespace: inet
class Ipv6NdPrefixInformation
IPv6ND Prefix Information RFC 2461 / RFC 4861 Section 4.6.2 RFC 3775 Section 7.2 (routerAddressFlag)
Usage diagram¶
Inheritance diagram¶
Extends¶
Name |
Type |
Description |
|---|---|---|
class |
(no description) |
Fields¶
Name |
Type |
Description |
|---|---|---|
type |
1 byte, 0 is invalid |
|
optionLength |
short |
The length of the option in units of 8 octets, 0 is invalid. // 1 byte |
paddingBytes |
char[] |
padding bytes on end of option |
type |
||
optionLength |
||
prefixLength |
unsigned short |
0..128 |
onlinkFlag |
bool |
L-bit |
autoAddressConfFlag |
bool |
A-bit |
routerAddressFlag |
bool |
R-bit: used in case of MIPv6 when the H-bit is set |
reserved1 |
unsigned int |
|
validLifetime |
uint32_t |
seconds |
preferredLifetime |
uint32_t |
seconds |
reserved2 |
uint32_t |
|
prefix |
Properties¶
Name |
Value |
Description |
|---|---|---|
packetData |
Source code¶
//
// IPv6ND Prefix Information
// RFC 2461 / RFC 4861 Section 4.6.2
// RFC 3775 Section 7.2 (routerAddressFlag)
//
class Ipv6NdPrefixInformation extends Ipv6NdOption
{
type = IPv6ND_PREFIX_INFORMATION;
optionLength = 4;
unsigned short prefixLength; // 0..128
bool onlinkFlag; //L-bit
bool autoAddressConfFlag; //A-bit
bool routerAddressFlag; //R-bit: used in case of MIPv6 when the H-bit is set
unsigned int reserved1 = 0;
uint32_t validLifetime; // seconds
uint32_t preferredLifetime; // seconds
uint32_t reserved2 = 0;
Ipv6Address prefix;
}