Ipv6NdOption¶
Namespace: inet
class Ipv6NdOption
(no description)
Usage diagram¶
Inheritance diagram¶
Extends¶
Name |
Type |
Description |
|---|---|---|
cObject |
(unknown – not in documented files) |
Known subclasses¶
Name |
Type |
Description |
|---|---|---|
class |
(no description) |
|
class |
IPv6ND Prefix Information RFC 2461 / RFC 4861 Section 4.6.2 RFC 3775 Section 7.2 (routerAddressFlag) |
|
class |
(no description) |
|
class |
MIPv6 Home Agent Information Option RFC 3775 Section 7.4 |
|
class |
MIPv6 New Advertisement Interval Option RFC 3775 Section 7.3 |
Fields¶
Name |
Type |
Description |
|---|---|---|
type |
1 byte, 0 is invalid |
|
optionLength |
short |
The length of the option in units of 8 octets, 0 is invalid. // 1 byte |
paddingBytes |
char[] |
padding bytes on end of option |
Properties¶
Name |
Value |
Description |
|---|---|---|
packetData |
Source code¶
class Ipv6NdOption extends cObject
{
@packetData;
Ipv6NdOptionTypes type = static_cast<Ipv6NdOptionTypes>(0); // 1 byte, 0 is invalid
short optionLength = 0; // The length of the option in units of 8 octets, 0 is invalid. // 1 byte
char paddingBytes[]; // padding bytes on end of option
}