Ipv6ExtensionHeader¶
Namespace: inet
class Ipv6ExtensionHeader
This serves as the base class for all the Ipv6 extension headers.
Usage diagram¶
Inheritance diagram¶
Extends¶
Name |
Type |
Description |
|---|---|---|
class |
(no description) |
Known subclasses¶
Name |
Type |
Description |
|---|---|---|
class |
Authentication Header RFC 2402 Not Implemented |
|
class |
Destination Options Header RFC 2460 Section 4.6 Next Header Value: 60 |
|
class |
Encapsulating Security Payload Header RFC 2406 Not Implemented |
|
class |
Fragment Header RFC 2460 Section 4.5 Next Header Value: 44 |
|
class |
Hop-by-Hop Options Header. RFC 2460 Section 4.3 Next Header Value: 0 |
|
class |
Routing Header RFC 2460 Section 4.4 Next Header Value: 43 |
Fields¶
Name |
Type |
Description |
|---|---|---|
id |
int |
|
mutable |
bool |
|
complete |
bool |
|
correct |
bool |
|
properlyRepresented |
bool |
|
chunkLength |
||
rawBin |
string[] |
|
rawHex |
string[] |
|
regionTags |
||
extensionType |
||
nextHeaderProtocol |
Next Header field (on the wire) |
Properties¶
Name |
Value |
Description |
|---|---|---|
beforeChange |
handleChange() |
|
descriptor |
readonly |
|
existingClass |
||
packetData |
Source code¶
//
// This serves as the base class for all the Ipv6 extension headers.
//
class Ipv6ExtensionHeader extends FieldsChunk
{
@packetData;
IpProtocolId extensionType = IP_PROT_NONE;
IpProtocolId nextHeaderProtocol = IP_PROT_NONE; // Next Header field (on the wire)
}