FieldsChunk¶
Namespace: inet
class FieldsChunk
(no description)
Inheritance diagram¶
Extends¶
Name |
Type |
Description |
|---|---|---|
class |
(no description) |
Known subclasses¶
Name |
Type |
Description |
|---|---|---|
class |
Packet for AckingMac. Packet size is configurable in the MAC layer. |
|
class |
(no description) |
|
class |
Base packet for AODV Control Packets |
|
class |
Generic application packet |
|
class |
(no description) |
|
class |
ARP packet. This is a specialized version: prepared for IEEE 802 hardware addresses and IPv4. Packet fields are therefore represented by C++ classes MACAddress and IPv4Address. Also, some ARP protocol header fields are not modelled explicitly (their values are implied): |
|
class |
Represents a BGPv4 message header. |
|
class |
Base class for BMac headers. |
|
class |
Represents a BPDU (Bridge PDU) used by the STP and RSTP protocols, as defined in the 802.1D-1998 specification. |
|
class |
Base header for the Connectivity Fault Management (CFM) protocol suite for managing connectivity at the Ethernet service level. CFM is defined within the IEEE Std 802.1Q-2018 standard, later IEEE 802.1ag and ITU Y.1731. |
|
class |
(no description) |
|
class |
(no description) |
|
class |
(no description) |
|
class |
(no description) |
|
class |
(no description) |
|
class |
(no description) |
|
class |
Represents a DHCP message. DHCP (Dynamic Host Configuration Protocol, RFC 2131) provides a framework for passing configuration information to hosts on a TCP/IP network. |
|
class |
(no description) |
|
class |
(no description) |
|
class |
Generic network protocol packet for testing network connectivity. |
|
class |
General structure of EIGRP message with header |
|
class |
Request packet sent by EtherAppClient. Contains the number of bytes to be sent back as response; if this value is greater than ~1400, the reply will consist of several Ethernet frames. See also EtherAppResp. |
|
class |
Packet sent back by EtherAppServer in response to an EtherAppReq. |
|
class |
This is a base class for all IEEE 802.3 Ethernet control frames defined the IEEE Std 802.3-2018, IEEE Standard for Ethernet. |
|
class |
This class represents an Ethernet FCS as defined in the section 3.2.9 Frame Check Sequence (FCS) field of the IEEE Std 802.3-2018, IEEE Standard for Ethernet. |
|
class |
This class represents the source and destination address fields of an IEEE 802.3 Ethernet MAC header as defined in the sections 3.2.3 Address fields, 3.2.4 Destination Address field, 3.2.5 Source Address field of the IEEE Std 802.3-2018, IEEE Standard for Ethernet. |
|
class |
This class represents the variable length padding part of an Ethernet frame as defined in the section 3.2.8 Pad field of the IEEE Std 802.3-2018, IEEE Standard for Ethernet. |
|
class |
This class represents the EtherType field of an IEEE 802.3 Ethernet MAC header as defined in the section 3.2.6 Length/Type field of the IEEE Std 802.3-2018, IEEE Standard for Ethernet. |
|
class |
(no description) |
|
class |
Message class for generic request-reply style applications. The client sends a GenericAppMsg which contains the number of bytes the client wants the server to send back as reply. |
|
class |
(no description) |
|
class |
The GPSR beacon packet is sent periodically by all GPSR routers to notify the neighbors about the router’s address and position. |
|
class |
ieee802.1AS-2020 10.6.2.1, 11.4.2 |
|
class |
(no description) |
|
class |
ICMP message class |
|
class |
Represents an ICMPv6 packet. |
|
class |
Frame body base class used to hide various frame body types |
|
class |
The common part of 802.11 frames. |
|
class |
(no description) |
|
class |
(no description) |
|
class |
(no description) |
|
class |
A CSMA mac header format definition |
|
class |
This chunk represents an IEEE 802.1AE tag header without the TPID field and with the following EtherType Protocol Discrimination (EPD) in the packet. The reason for this shifted representation is that it’s often easier to look at an 802.1AE tag this way during processing. The typeOrLength field contains the EtherType as defined in the section 9.2 EtherTypes of the IEEE Std 802-2014, IEEE Standard for Local and Metropolitan Area Networks: Overview and Architecture. |
|
class |
This chunk represents an IEEE 802.1AE tag header as defined by the section 9.3 MAC Security TAG of the IEEE Std 802AE-2018, IEEE Standard for Local and metropolitan area networks, Media Access Control (MAC) Security. |
|
class |
This chunk represents an IEEE 802.1Q tag header without the TPID field and with the following EtherType Protocol Discrimination (EPD) in the packet. The reason for this shifted representation is that it’s often easier to look at a 802.1Q tag this way during processing. The typeOrLength field contains the EtherType as defined in the section 9.2 EtherTypes of the IEEE Std 802-2014, IEEE Standard for Local and Metropolitan Area Networks: Overview and Architecture. |
|
class |
This chunk represents an IEEE 802.1Q tag header as defined by the section 9.3 Tag format of the IEEE Std 802.1Q-2018, IEEE Standard for Local and Metropolitan Area Networks, Bridges and Bridged Networks. |
|
class |
This chunk represents an IEEE 802.1R tag header without the TPID field and with the following EtherType Protocol Discrimination (EPD) in the packet. The reason for this shifted representation is that it’s often easier to look at a 802.1Q tag this way during processing. The typeOrLength field contains the EtherType as defined in the section 9.2 EtherTypes of the IEEE Std 802-2014, IEEE Standard for Local and Metropolitan Area Networks: Overview and Architecture. |
|
class |
This chunk represents an IEEE 802.1R tag header as defined by the section 7.8 Tag format of the IEEE Std 802.1CB-2017, IEEE Standard for Local and Metropolitan Area Networks, Frame Replication and Elimination for Reliability. |
|
class |
This chunk represents an IEEE 802.2 LLC header as defined by the ANSI/IEEE Std 802.2, 1998, IEEE Standard for Information technology, Telecommunications and information exchange between systems, Local and metropolitan area networks. |
|
class |
This chunk represents an IEEE 802.2 LLC header SNAP extension as defined by the section 9.5 SNAP of the IEEE Std 802-2014, IEEE Standard for Local and Metropolitan Area Networks: Overview and Architecture. |
|
class |
This class represents an IEEE 802 EtherType Protocol Discrimination (EPD) header as defined in the section 9.2 EtherTypes of the IEEE Std 802-2014, IEEE Standard for Local and Metropolitan Area Networks: Overview and Architecture. |
|
class |
(no description) |
|
class |
IPsec AH header (RFC 4302). |
|
class |
IPsec ESP header (RFC 4303). |
|
class |
IPsec ESP trailer (RFC 4303). |
|
class |
This serves as the base class for all the Ipv6 extension headers. |
|
class |
Base class for LDP packets |
|
class |
Packet for disseminating link state information (TeLinkStateInfo[]) by the LinkStateRouting module which implements a minimalistic link state routing protocol. |
|
class |
Base class for LMac headers. |
|
class |
(no description) |
|
class |
(no description) |
|
class |
MRP_SubTLVHeader: Generic header for SubTLVs used in more detailed MRP configurations. |
|
class |
MRP_TLVHeader: Base class for all TLVs in MRP; contains the Type and Length fields of the TLV. Note that all TLVs (except for MRP_End) must be padded to a multiple of 32 bits. |
|
class |
MRP_Version (non-TLV field): Specifies the version of the MRP being used. |
|
class |
(no description) |
|
class |
Represents an OSPF packet header |
|
class |
This is a base class for all IEEE 802.3 Ethernet PHY headers defined the IEEE Std 802.3-2018, IEEE Standard for Ethernet. |
|
class |
(no description) |
|
class |
(no description) |
|
class |
Header |
|
class |
PPP frame. |
|
class |
(no description) |
|
class |
(no description) |
|
class |
(no description) |
|
class |
(no description) |
|
class |
(no description) |
|
class |
RIPv2 packet |
|
class |
RSVP message common part |
|
class |
(no description) |
|
class |
This class represents an RTP data packet. Real data can either be encapsulated, or simulated by adding length. |
|
class |
(no description) |
|
class |
(no description) |
|
class |
(no description) |
|
class |
(no description) |
|
class |
Represents a voice packet used by SimpleVoipSender / SimpleVoipReceiver |
|
class |
(no description) |
|
class |
This base class provides an abstraction for different transport layer packets. |
|
class |
Represents a TCP/UDP pseudo header, used for checksum calculation. |
|
class |
Packet type used by VoIPSourceApp and VoIPSinkApp |
|
class |
Base class for XMac headers. |
Fields¶
Name |
Type |
Description |
|---|---|---|
id |
int |
|
mutable |
bool |
|
complete |
bool |
|
correct |
bool |
|
properlyRepresented |
bool |
|
chunkLength |
||
rawBin |
string[] |
|
rawHex |
string[] |
|
regionTags |
Properties¶
Name |
Value |
Description |
|---|---|---|
beforeChange |
handleChange() |
|
descriptor |
readonly |
|
existingClass |
||
packetData |
Source code¶
class FieldsChunk extends Chunk
{
@existingClass;
@descriptor(readonly);
}