Ipv6NdMessage¶
Namespace: inet
class Ipv6NdMessage
Neighbour Discovery for Ipv6. RFC 2461
ICMP fields inherited from ~Icmpv6Header:
Type
ICMP fields not implemented:
Checksum
Reserved
Inheritance diagram¶
Extends¶
Name |
Type |
Description |
|---|---|---|
class |
Represents an ICMPv6 packet. |
Known subclasses¶
Name |
Type |
Description |
|---|---|---|
class |
Neighbour Advertisement Message Format RFC 2461 Section 4.4 |
|
class |
Neighbour Solicitation Message Format RFC 4861 Section 4.3 |
|
class |
Redirect Message Format RFC 2461 Section 4.5 |
|
class |
Router Advertisement Message Format RFC 2461 Section 4.2 RFC 3775 Section 7.1, RFC 5175 Section 3. (homeAgentFlag) |
|
class |
Fields¶
Name |
Type |
Description |
|---|---|---|
id |
int |
|
mutable |
bool |
|
complete |
bool |
|
correct |
bool |
|
properlyRepresented |
bool |
|
chunkLength |
||
rawBin |
string[] |
|
rawHex |
string[] |
|
regionTags |
||
chunkLength |
||
type |
1 byte int code; // 1 byte //TODO this should be specific to different ICMP types. |
|
chksum |
int |
2 bytes |
checksumMode |
4 bytes ‘type’ specific values |
|
code |
int |
Properties¶
Name |
Value |
Description |
|---|---|---|
beforeChange |
handleChange() |
|
descriptor |
readonly |
|
existingClass |
||
packetData |
Source code¶
//
// Neighbour Discovery for Ipv6.
// RFC 2461
//
// ICMP fields inherited from ~Icmpv6Header:
// - Type
//
// ICMP fields not implemented:
// - Checksum
// - Reserved
//
class Ipv6NdMessage extends Icmpv6Header
{
int code = 0;
}